Fandom

OpenArena

Mapping manual/Your first map

< Mapping manual

373pages on
this wiki
Add New Page
Talk0 Share

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.

The interface Edit

Generally speaking, every editor has several views which can be organized in order to fit the mapper's needs; among them we can appreciate:[1]

  • (C) The Camera view, a 3D look of how the unlit map brushes are organized in your map.
  • (XY) The 2D Upper view.
  • (XZ) The 2D Front view.
  • (YZ) The 2D Side view.
  • (T) The Texture browser.
  • (O) The Console output.
  • (XYZ) A customizable 2D view capable of switching between XY-XZ-YZ views.

In many editors for other games, you can adapt your window viewport arrangement to your needs. In the *Radiant editors, however, you only have four predefined arrangements:

  • Default: (XYZ) to the very left, (C) to the top-right, (T) to the middle-right, and (O) covering the whole bottom.
  • Floating: Three separate, floating window viewports, with the (XYZ), (C) and (T) views.
  • Four-square: The interface is divided in four quadrants: (C) at top-left, (XY) at top-right, (XZ) at bottom-left and (YZ) at bottom-right.
  • Default inverted: Same as Default, except that (C) and (T) occupy now the left side and (XYZ) is located at the right side.

The most recommended view to use is the Four-square one, as it covers every area the mapper needs, and the Texture Browser and Console Output can be called later anyway.

Keyboard Edit

It's strongly recommended that you learn how to make your way throughout the editor with the keyboard. Here are the most common navigation keys:

Key Function
Moving in all directions
Forward (facing direction)
Backwards
Turn left
Turn right
D Move (swim) up
C Move (swim) down
A Look up
Z Look down
End Level view
"Flying" through the map
Forward (facing direction)
Backwards
Turn left
Turn right
Zoom with a view
Delete Zoom In
Insert Zoom Out
Other
CTRL + MMB* On a 2D map, (C) moves to the pressed location.
Hold RMB** Drags the 2D view.

Prior advices Edit

Remember that, if your editor supports it[2], you should check if the option "Always use caulk for new brushes" (in Edit menu -> Preferences -> Settings -> Brush) is activated. There's another option you should check, and it's "Clipper tool uses caulk" in Edit menu -> Preferences -> Settings -> Clipper. You don't want to deal with FPS mess from your very beginnings, don'tcha?

Creating a first room Edit

Obviously the first thing you need to do is to start with a blank slate. Go to File -> New map.

The first brush: the floor Edit

Put your mouse in (XY) in the coordinates (256,-256), then drag the mouse to coordinates (-256,256). That's it! Now let's make the rest of the room. Press ESC, so no brushes are selected.

The walls Edit

Now go to the (YZ) view and put the cursor at the (-384,64) point. Drag up to the (-256,576) point. Press ESC. Now go to the (384,64) point and drag another brush up to the (256,576) point. Now go to the (XZ) view, select the bottom brush, deselect it, and do the same as before: draw a brush from (-384,64) to (-256,576) first, then ESC, then draw from (384,64) to (256,576).

We'll texture these walls later. As in real life construction, foundation comes first, painting comes later.

The ceiling Edit

Now that we have the floor and the walls, we need a ceiling. In the XZ view, select the floor brush first. Now, draw a brush from the point (704,-256) all the way to (576,256). This way, our first room should be all set.

Texturization Edit

Now we have the first room, but it's a big pink/blue area. Let's make some stuff from it. Summon the Texture Browser (T). Hold Ctrl and Shift, then Left Click on the floor in (C). Now the floor is selected. Go to acc, then acc_dm3, then select the concrt texture. Now the floor is textured with the acc_dm3/concrt texture. If you don't deselect the floor, you can still change its texture to fit your needs.

Now let's do the same for the walls and the ceiling. Deselect everything with ESC. Hold Ctrl and Shift, then keep clicking each of the four walls. The four walls are now selected. Now go to (T) and select the wallloop texture. See how the walls have now the same texture? Now deselect everything with ESC and select the floor. As the texture we need for the sky isn't in the acc_dm3 package, we shall go to the skies package instead. Select nitesky.

Playerstarts Edit

In order to make our room playable, we also need a starting point. Deselect everything and go to (XY). Select one of the walls, deselect it, and in the center of the room, do RMB -> info -> info_player_deathmatch. Go to either the (XZ) or (YZ) view, hold LMB and try to keep this new "box" to the floor, but not too close or touching it. Press ESC.

Playtesting Edit

Now that the room is finished, you want to see how it's going to look ingame, don'tcha? Well, first put a name to your map, go to File -> Save -> myfirstmap.map. Now go to Build -> Q3Map2: (single) BSP -meta -flares. This should create a myfirstmap.bsp file in your baseoa/maps/ folder.

Now, open the game. Drop the console and write /sv_pure 0, this turns the "Pure server" option off, otherwise you cannot run your level in the game. Now write the line /devmap myfirstmap, without the .bsp extension. And that's it! Your first level is now created.

Creating a second room Edit

Let's further up the things.

Creating a corridor Edit

Connecting both rooms Edit

Why not hollowing? Edit

You may notice there's a Hollow function which automatically creates from a single brush the six brushes we just made. The thing with this tool is that it doesn't create the rooms as well as we did. The rooms created with this tool have invisible faces which have an impact on how the game engine calculates. You can fix small, square rooms easily, but the problem increases with complex shapes such as brush-based cylinders. More on this on the O+T page.

Notes Edit

  1. Getting Around In GTKRadiant from Wikibooks
  2. GTKRadiant 1.6 and almost any version of NetRadiant supports it.

External links Edit

<< Previous (Choosing an editor) Mapping manual (Brush manipulation) Next >>


OpenArena's Mapping manual
Prologue /// Pre-mapping stage - Map gameplay /// Choosing an editor /// Your first map
Brush manipulation - 2D/3D clipping /// Curve manipulation /// Textures /// Introduction to Entities
Lighting - Advanced lighting /// Weapon/Item placement /// Triggers and movers - Dynamic features
Shaders /// Terrains and liquids /// Mapmodels /// Sounds /// Gametype support
Optimization and Troubleshooting - Hint brushes - Bot play - Troubleshooting
Final touches /// Compilation & packaging
Glossary of terms - Advanced features - Modelling a map - Editor differences - Default assets (Textures/Models/Sounds) - GPL

Also on Fandom

Random Wiki