Wikia

OpenArena

Bugs

Talk9
363pages on
this wiki

This page is dedicated to list bugs found in the current version of the game. This is mostly a recap of what is suggested on the forums, let's try to maintain the two things synchronized.

READ BEFORE EDITING Edit

  • Go straight to the point. This means: don't add words just to make your entry look cool. Walls of text and "purple prose" are discouraged, as they make reading difficult. In this case the required info are the description of the bug itself and when it's being triggered. Everything else, including trivia, has nothing to do with the entry and should be avoided.
  • To suggest possible new features, instead, there is the "Wishlist" page.
  • Issues which won't be fixed anytime soon are placed in the Bugs/Rejected page.
  • It's highly suggested to report bugs on the forum, then mention them here, linking to the specific forum post for more info.
  • When a problem is fixed, move it to the "Already fixed" section below. This means that in the next OpenArena version the problem should not occur anymore.
  • When that new version (containing those bugfixes) will be official and public, please move those entries to the Bugs/Archive page.
  • Part of these "0.8.8" bugs may have been discovered in OA 0.8.5 and they are still "open", probably because they have not been fixed yet, but in some cases it may be because the list has not been updated correctly yet. 0.8.5 bugs already resolved at 0.8.8 release have been moved to Bugs/Archive page.
  • Also regarding 0.8.8, bugs regarding cut content won't be fixed.

Known bugs and status in 0.8.8: Edit

General Edit

  • Problem: it does not show text for picked up items if you enable \cg_alwaysWeaponBar 1. And it does not write the name of the weapon you are selecting. Related post.
  • When you enter Multiplayer menu, it "remembers" the last filters/order you used. But if you last de-selected "hide private" option, the next time you enter the menu, it is not remembered. Related pot.
  • Favorites list can store up to 16 servers. When all slots are already used, and you try to add another server, you should get an error message! Now the server is simply not added (no message, not even in console!). Related post.
  • Sometimes, adding a new server to Favorites makes the existing ones disappear. Related post.
  • It has been reported that, in Mission Pack, using favorites may crash the game. Related post.
  • There are some little strange things when one goes to set the crosshair options ("game options" menu) before playing his very first match right after installing the game. Related post.
  • In the missionpack, the HUD color is always "neutral", while it should look red when you are on the red team, and blue while you are on the blue team... Related post
  • With cg_weaponbarstyle 2, 3, 4, 5, 6, 7 and elimination_grapple 1 (in Elimination mode or similar), the icon of the grapple is not loaded (appearing as missing) until you select it. Related post.
  • If the server changes the g_motd cvar (the short Message of the day), the clients will see the new text only after the server re-started the map (or loaded another one). Reated post.
  • If you disable draw rewards (\cg_drawrewards 0), play well, and then re-enable the feature, all the medals you earned in the meanwhile are shown, one after the other. Related post.
  • Manually adding bots, specifying their team (or using !putteam admin command), may lead to strange behaviors, where a bot appears of a team (in its color and in the score table), for example red, but acts like a player of the other team, for example blue, attacking red players, sending "team chat" messages to the blue team, and capturing the red flag (scoring for the blue team). Related post.
  • If someone customizes the killing sprees messages, he can set "printpos = 1" to have them shown centered, instead of in the console. But in this case only the other players will see the message, not the player that gets the killing spree (maybe the "you fragged xxxxx" message "covers" it). More, the font used with "printpos = 1" is big, and allows about 40-43 characters max... that are not much: for example, a "Player is on a killing spree!!! ( 5 kills!!! )" message is 47 characters long and would end out of the screen! Related post.
  • The icons for the Neutral Flag (also used in Domination) and the Red and Blue skulls are missing.
  • In Harvester, the "Player team scores" guitar riff plays when the rival team scores, and the "Rival team scores" guitar chords play when the player team scores.
  • If you use PHP or another server-side language on your webserver to serve the autodownload files, you need to send a 'Content-Length' header. Otherwise the OpenArena client will crash! Maybe an error message would be better than a crash. Related post.
  • Unless using an expressly-modifed dpmaster server (e.g. sv_master2=dpmaster.version6.ru, see here for info about it), IPv6 OpenArena servers are not listed (even if using an IPv6 client). Related post.
  • "!Mute" command in admin system does not seem to work. Mentioned here and here.
  • Pointed out with 0.8.5: the voting procedure sometimes does not show the description of the current vote (causing players do not know what is the question they have to answer yes or no). It has been hypotized here that this may happen when there are many players in the server (around 16), and you are not the one that called the vote. This hypotesys should be checked with both OpenArena 0.8.5, and with 0.8.8 (in this case, with both dmflags 0 and dmflags 512).
  • Pointed out with 0.8.5 with many players in the server and (probably) a shuffle vote (please read here): after vote passed, player has been kicked out, with console showing messages such as "ERROR: CL_GetServerCommand: a reliable command was cycled out" and "Received signal 11, exiting... (I crashed it)".
  • If you set vertex lighting (r_vertexlight 1), then (from ESC menu during a match, not from the main menu!) access "Setup" menu, you see a grey background (instead of black) that makes reading very difficult. See screenshot here. Noticed with OpenArena 0.8.8.
  • In Elimination mode, during the "inactive" elimination warmup, players of one of the two teams spawn in a place where there should not be swpan points (e.g. underwater, in a wall...), and immediately die; then they can only spectate other players, until the "active" warmup time begins (at that time, they spawn again and take control of their character). Related post
    • If also g_dowarmup (generic warmup) is active, they will experience the instant death two times: the first at the beginning og the g_dowarmup time, and the second at the beginning of the "inactive" elimination warmup. It seems to affect Elimination (gametype 8) and CTF Elimination (gametype 9), but not Last Man Standing (gametype 10, similar but without teams) mode.
    • Also related to the above, in Elimination and CTF Elimination, just after initial map loading, you can see the arena from an unexpected point of view, for a few moments. This is due to the fact that the spawn-routine is disabled until the warm-up begins, and thus you will see the map from 0,0,0 (facing 360) coordinates for a while. It's not a major problem (you will correctly spawn soon: this time depends from the difference between elimination_warmup and elimination_activewarmup variables), but anyway, the case 0,0,0 may be the external void or inside a wall. It can be noticed in few situations only, e.g. while starting the map from the Skirmish menu. Mentioned in Sago's reply to this post.
  • In Elimination mode, during the "waiting for players" phase (and in case "g_dowarmup" is enabled, also during the generic warmup), part of weapons sounds are not played. Probably it's a bug, considering that it does not affect g_dowarmup while playing in Deathmatch (g_gametype 0) or TDM (gametype 3), even with g_elimination 1. It seems to affect Elimination (gametype 8) and CTF Elimination (gametype 9), but not Last Man Standing (gametype 10, similar but without teams) mode. Related post.
  • OA 0.8.8 added the "cascaded" version of Bloom graphic feature, but it had a glitch. The fix should be here, but still has to be applied to test binaries.
  • OA 0.8.8 added the support for GLSL effects. A little fix for their console output has been created here, but still has to be applied to test binaries.
  • Observed that a server is indicated as empty ( 0 / x players) in the in-game server browser while qstat server queries (ping > 0) and entering the server confirmed that 2 human players are there (one with empty name -> NamelessX and one with some plain unstyled name). Note: Number of human players are counted by the server. If the server uses an alternative binary without human player count support. Then the numbers will be wrong.
  • Since OpenArena 0.8.5, "cl_yawspeed" and "cl_pitchspeed" are hardcoded to 140.0 value. But the variables do not result as "read-only" or "cheat-protected", you simply change them but they have no effect: this may be confusing and seem a bug. It should be clearer that they are protected, and there could be some server-side way to disable the lock, or maybe allowing some ranges of freedom. Related thread. An update here.

Maps Edit

  • If oa_koth2 is launched from the Single Player Deathmatch tier 4 of OpenArena 0.8.8, flames of torches "blink" intermittently. If loading the map from multiplayer/skirmish or from console, instead, such flames are shown without the graphic glitch. Related thread.
  • A problem with a shader: "evil8_fx/e8jumpspawn02red"... that shader is located in pak6-patch088.pk3/scripts/evil8_base.shader. It should be animated, but it's not. It looks like its "animmap" stage loads various image files, but all those images look the same! It seems more shaders under evil8_fx folder may have the same problem.... they should be checked and fixed, if necessary. Related thread.

Weapons, characters and models in general... Edit

  • Your lightning gun (and maybe also your gauntlet) can fire also from your dead body, causing strange effects. You can easily test it in Elimination mode on map am_galmevish. Read also here.
  • With cg_oldrail 0, when you shoot with the railgun aiming to a very far object, the inner trace is not drawn. When aiming at other distances (still very far), the inner trace is not drawn and the outer spiral "begins" far, far away from you (unless you use zoom, it is difficult to see the spiral). To try, go to wrackdm17, take the railgun and begin shooting at the opposite "invisible wall" of the map, at various heights. See also here. Also opened bug on ioquake 3 bugzilla here.
    • UPDATE - WARNING: This "graphic" bug may somehow be related to a gameplay limitation of the railgun... the railgun range is limited to 8192 units (the machinegun range is 16 times longer)... probably, if you can see the graphic bug, this means that you cannot hit your target (independently from your cg_oldrail value... try it in cbctf1 map)... thus maybe correcting the graphic bug without extending the weapon range may not be the best solution (removing the only sort of "indication" of being out of range)... I think that -if you don't want to extend the railgun range- fixing the graphic bug and adding some "out of range" or "too far" message after a similar shot would be a much more elegant solution. Please read this topic.
  • There's no 3D model for the post-match podium.
  • If cg_leiEnhancements is set to 1, then your cg_oldplasma value is ignored, and you always see it like with cg_oldplasma 1. Detected in OA 0.8.5 and still there in OA 0.8.8.
  • The grapple AI logic for bots has many bugs: it's unclear if they try to pick-up the grapple or not... if they fire the grapple and miss the edge of the target wall, they try again without correcting the aim... if they have to go to a place where they would have used grapple but don't have it yet, they start pointlessy firing at that place with standard weapons. Related post. Also: this and this.
  • Updating cg_weaponorder default value to integrate weapons 11, 12 and 13. Considering that if a weapon is not in the list, this prevents both autoswitching FROM and TO that weapon (in modes 3 and 4), it is important all weapons are there. See Related post.

Sounds Edit

  • Sounds when taking a flag is quite chaotic.
  • Mechanical sound when changing weapon is too much.
  • flagcap.wav (you are on red team, and red team scores) plays half speed and half length on SDL, plays twice on SDL and OpenAL Should be mono, not stereo?
  • When you spectate a player in a CTF game, the "enemy has your flag" sound is not played when it should.
  • In Elimination, when the character falls, the damage-taken sound should be disabled if the character does not take damage.
  • Record some specific sounds (announcer voice, short music or sound effects?) for Killing Sprees, Death Sprees and Multikills, and place them (together with an updated sprees.dat text file) in the next patch pk3. At the moment, these re-use "excellent" and "humiliation" sounds, by default. Some players may get confused. Apposite thread here.
  • When the music track restarts, a yellow warning message tells that the music format is not 22khz stereo. Maybe OA music introduced in 0.8.8 has got higher sound quality than music thought for original Q3A? Maybe we could make that warning appear only when using verbose console output (developer 1), OR when the format is different than both 22khz and 44khz? In the case that the game cannot get any advantage by using music higher than 22khz, The music files might be re-encoded to strictly follow that format. Related post.

Workarounds Edit

  • With Anaglyph stereoscopic view enabled (r_anaglyphmode <> 0), the crosshair is not shown, and the optional info in the upper right corner (framerate, speed...-if enabled-) are messed up. Screenshot. A possible solution has been proposed (for at least part of the problem).
  • In Overload mode, bots act strangely, shooting at the "client 0" player, even if he's their own team-mate, if the obelisk is not perfecly aligned with the ground (the origin must touch the floor).
    • Mappers should ensure that the obelisk's origin is touching the floor, regardless if the model does it or not. Read here.
    • The "origins" of the 3D models of the obelisks (and maybe some other models) are not correctly aligend, making difficult to place them correctly. In this thread (may 2009) there are some corrected models, but probably they have not been committed to the SVN yet (january 2012).
    • PARTIALLY FIXED: As of 0.8.8, maps with this problem have been fixed. The model still needs a tweak, however.
  • If you don't have OpenAL installed and/or activated (problem found with Windows XP and OA 0.8.5), if you change mod using the "mods" menù, the sound will stop working. No problem if you launch the mod directly from Windows' command prompt (for example openarena.exe +set fs_game missionpack). See here on the forum.
    • In this thread, more test have been done: a snd_restart command makes the sound work again; Sago argued that, maybe, under Windows, the video and sound systems may need to be loaded in a specific order...
  • Bots still cause Server Shutdown (Server crashed: netchan queue is not properly initialized in SV_Netchan_TransmitNextFragment) - AAS shutdown on dedicated servers.
    • The .bsp map needs a valid .aas file created with the same version of the map. Maybe related with this or with this.
  • When the music track re-starts, a very noticeable drop in frames-per-second may occur for a short time. That might be somehow related to the 22khz warning message or not. A simple workaround to avoid it is to set s_musicvolume 0, but this means renouncing to music. A real "fix" would be welcome. Related post.

Already fixed Edit

  • The following spacemaps lack the falling sound when falling to the void: cbctf1, czest1tourney, oa_ctf2 and oa_ctf2old. (This has to wait until the next version)
  • Some objects (usually, lights) show a glitch of a thin colored border where they should be transparent, showing an edge that should be invisible. Textures used in those models should be fixed this way...
  • Graphic glitch on oa_ctf4ish: it is possible to look through a jump-pad or two (problem noticeable from specific angles), as shown in the screenshot here.
  • Probably depending from your framerate, gauntlet spinning may look strangely, with the outer part of the blade seeming to rotate slower than the inner part. Maybe an engine problem that cannot be fixed? Or something can be done to the weapon model to limit the effect?
    • OA3 will replace the Gauntlet model with a drill.
  • kyonshi, gargoyle and major lack swimming animations
    • Kyonshi is currently undergoing a redesign. Gargoyle is also being worked. Major is going to be revorked or removed.
  • An user reported that maybe Gargoyle's run animation is a bit too slow considering the actual moving speed. Maybe the animation should run a little faster? Detected in OA 0.8.8. Info here.
    • Gargoyle is being worked.

External links Edit

See alsoEdit

Around Wikia's network

Random Wiki